Archive for the ‘Windows8’ Category

During the process of numerous upgrades of the OS during the Windows 10 technical preview, I’ve found quite often that my Windows Apps often stop working properly, or display as non functioning icons showing the meaningless name of the app instead of the proper app tile.

Two quick things to try to resolve:

  1. From an elevated command prompt run “wsreset”
    1. This will trigger a “Windows Store Reset” and may or may not resolve any initial problem you have opening the Store App
  2. From an elevated Powershell prompt, run the following
Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

This should re-register all the apps that appear in your app cache.

There are still many other potential issues you might encounter such as proxy servers blocking access or corrupt apps, but it’s a relatively easy starting point.

Advertisements

I’ve done upgrades on several computers and for the most part never had an issue, but everyone now and then I have found that while the Windows install goes all the way through the installation and device setup, it then seems to get stuck during the very last “Setting up a few more things” stage, sometimes stopping at a frustrating 79%!

I’ve tried leaving them for several hours but it never gets past that point. A hard reset is the only option, after which Windows restores the previous version. So at least nothing is lost other than time.

In all cases though, I’ve found the problem is having the Hyper-V role installed. There must be something about the Hypervisor that causes a problem.

After the OS rolls back, go into roles and features and remove the Hyper-V role, then try the upgrade again. After it completes just add the Hyper-V role back in again and it should pick up all the previous settings.

I don’t have a fix of my own for this, but I am seeing a lot of people finding my site through various search engines from my previous Windows RT fix. This is not an issue I have experienced and at the moment is not something I am looking into.

If you need help then the following Microsoft article has some details on a fix.

http://support.microsoft.com/kb/2982791

If you know of another site with more “friendly” instructions, let me know and I’ll link it here. If this problem persists, or if I encounter it myself I will look to post my own fix if nothing else appears from Microsoft.

Have you noticed that the Metro / ModernUI Internet Explorer has gone missing or only starts the desktop version?

If you don’t like the “full-screen” Metro / Modern UI version of Internet Explorer, then this post is for you.

If you do like it, then this post is for you also.

I for one do like the ModernUI version of IE, both on the desktop and on my Surface. On the desktop I mostly use it when reading news sites and such, but it still serves a purpose for me.

Today I noticed it wasn’t working anymore. When I click the big ‘e’ icon on the Start Screen it would switch over and start the desktop version. I tried doing a search on my desktop for Internet Explorer, but still, only the desktop version would appear. Most peculiar.

After a bit of digging around I found the following option to “Open Internet Explorer tiles on the desktop” under the IE options Programs tab, but it was greyed out and I couldn’t change it. Most peculiar

ie-opt-grey

(more…)

Many devices are capable of “waking up” the computer, and often I find my computer has decided to wake itself up in the middle of the night because of one of them.

(See also: “Computer wakes up for no reason“)

You can dig through Device Manager to find and disable the “Allow this device to wake the computer” options, but this is tedious and also difficult if you don’t know which device to change. Windows also has this neat “trick” where if you disable wake up on a device, and then plug it into a different USB port, Windows will see it as a *different* device which it then enables wake up for again.

(more…)

PLEASE NOTE: Now that Microsoft has released their officially supported fix I am no longer providing the download for the recovery drive. If you wish to keep a small recovery drive then repair your system using the instructions from Microsoft, then follow “Option 1” to create a new small boot drive.

Microsoft have now released the Full Recovery Image for WinRT (3.7GB download). You can get it here http://www.microsoft.com/surface/en-us/support/warranty-service-and-recovery/surface-rt-startup-error-0xc000000d?lc=1033 

It uses the same steps to complete the upgrade with the last part being to recreate the full recovery volume. Some news sites are saying the MS image will revert you to 8.0, it does not. It will complete the 8.1 upgrade and then the extra steps are to recreate the on-device recovery volume with the 8.0 image which only applies if you rollback sometime in the future.

COMMENT: I’ve also received confirmation that my approach works on a Japanese and other non-English language WindowsRT devices, which is good news as that’s not a test I could have done, and hadn’t even considered tbh. Also, While I refer to “Surface” because that’s what I have. these steps will also apply to any WindowsRT tablet device.

So something has gone horribly, horribly wrong. You do of course have the USB key you created shortly after setting up your Surface, don’t you?

Don’t worry, even though I do this sort of thing for a living, even I hadn’t created a recovery USB Key. Luckily for me though (or unlucky depending on how you look at these things), I have two Surface tablets. After the Win8.1 upgrade, one worked fine, the other suffered the Boot Configuration failure – https://kickthatcomputer.wordpress.com/2013/10/19/windows-rt-8-1-upgrade-fails-with-boot-configuration-error/

So here I’m going to describe the ways I’ve found to create your recovery USB key. Make sure to read to the end because you will most likely also need to recover your BitLocker encryption key as well (it’s like the complications never end!)

(more…)

UPDATE 19 August 2014 regarding KB14-045 bluescreens:

Although I don’t have a fix, there seems to be a lot of people finding this post while searching about the recent bluescreen issue caused by Microsoft Updates KB14-045. I have started a new post about this issue here:

https://kickthatcomputer.wordpress.com/2014/08/19/windows-update-kb2982791-ms14-045-causing-bluescreen/


Microsoft have now released the Full Recovery Image for WinRT (3.7GB download). You can get it here: http://www.microsoft.com/surface/en-us/support/warranty-service-and-recovery/surface-rt-startup-error-0xc000000d?lc=1033

It uses the same steps to complete the upgrade with the last part being to recreate the full recovery volume. Some news sites are saying the MS image will revert you to 8.0, it does not. It will complete the 8.1 upgrade and then the extra steps are to recreate the on-device recovery volume with the 8.0 image which only applies if you rollback sometime in the future.

First point – How annoying is it that you can only update Windows RT from the App Store, although probably not a drama if you only have one tablet. Slightly annoying if you have two. Both need to download the update, so that’s 2x the several GB needed. If you happen to be an enterprise/business that decided to buy several of them (does such a entity exist?) then it would appear you are about to have a ton of downloads happening unless you boost your proxy cache size.

And now for todays story. I updated one Surface RT with no drama. It took a long time but I just let it run overnight and it was all good the next morning. The other tablet, not so good.

WP_002371 (768x1024)

Recovery
Your PC needs to be repaired
The Boot Configuration Data file is missing some required information
File: \BCD
Error code: 0xc000000d

Yay.

Although it takes a while, and might be a bit tricky, it does seem to be fairly easy to recover from. (UPDATE: I have now received multiple confirmations that this works, and no data is lost!)

(more…)

Last update: 6/2/2014 Link to Microsoft TechNet article response

When runnning a Windows 7 or Windows 8 OSD install task sequence on ConfigMgr 2012 SP1 (CU2 and CU3), I’ve noticed that it seems to get stuck and appears to hang for a while when it gets to the “Install Software Updates” step. Typically it will sit there for 5- 10 minutes or so with no apparent activity before it starts applying the updates as required. The updates do eventually apply and the build completes as normal.

(more…)